<!doctype html>
<html lang="en-US" class="">
<head>
	<meta charset="UTF-8">
		<meta name="viewport" content="width=device-width, initial-scale=1">
		
	<link rel="profile" href="https://gmpg.org/xfn/11">
		<title>Where to Find Free Drive-Thru Walgreens COVID Testing Near Chicago &#8211; NBC Chicago</title>
<link rel='dns-prefetch' href='//ak.sail-horizon.com' />
<link rel='dns-prefetch' href='//native.sharethrough.com' />
<link rel='dns-prefetch' href='//js-sec.indexww.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="NBC Chicago &raquo; Feed" href="https://www.nbcchicago.com/?rss=y" />
<link rel='stylesheet' id='all-css-0' href='https://www.nbcchicago.com/_static/??-eJylzElOBCAQheEL2UzFuDAuPElRFEpkMILx+t3GeADb9fvfJ7/eL7Tm4XnkeeXBW85Ml33wtDUl9fa95M/Wi6S9Ja0x1hQ+qeSRKHEoEWxEdEmMNsWteZB/NF/6ytgFqBhVjVE7CsBQMqdyt4kfp1FnkYNCiDVhBgPFFjaR/4s+/1yEJ22tz7UGQCoBAKy+28590dsWtXiXjdHkNVcEFaILv+bTeNQetEnOeHcFfySZBQ==' type='text/css' media='all' />
<script id='ad-layers-dfp-js-extra'>
var adLayersDFP = {"layerDebugLabel":"Current ad layer","consoleDebugLabel":"Switch to Google console","adUnitPrefix":"div-gpt-ad-"};
</script>
<script src='https://www.nbcchicago.com/wp-content/plugins/ad-layers-nbc/js/ad-layers-dfp.js?ver=0.0.9' id='ad-layers-dfp-js'></script>
<script id='ad-layers-js-extra'>
var adLayersAdServer = {"jsAPIClass":"AdLayersDFPAPI"};
</script>
<script src='https://www.nbcchicago.com/wp-content/plugins/ad-layers-nbc/js/ad-layers.js?ver=0.0.9' id='ad-layers-js'></script>
<link rel="https://api.w.org/" href="https://www.nbcchicago.com/wp-json/" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.nbcchicago.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.nbcchicago.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.5.6" />
<link rel="canonical" href="https://www.nbcchicago.com/news/local/where-to-find-free-drive-thru-walgreens-covid-testing-near-chicago/2609969/" />
<link rel="alternate" type="application/json+oembed" href="https://www.nbcchicago.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.nbcchicago.com%2Fnews%2Flocal%2Fwhere-to-find-free-drive-thru-walgreens-covid-testing-near-chicago%2F2609969%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.nbcchicago.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.nbcchicago.com%2Fnews%2Flocal%2Fwhere-to-find-free-drive-thru-walgreens-covid-testing-near-chicago%2F2609969%2F&#038;format=xml" />
		<style>
		.getty.aligncenter {
			text-align: center;
		}
		.getty.alignleft {
			float: none;
			margin-right: 0;
		}
		.getty.alignleft > div {
			float: left;
			margin-right: 5px;
		}
		.getty.alignright {
			float: none;
			margin-left: 0;
		}
		.getty.alignright > div {
			float: right;
			margin-left: 5px;
		}
		</style>
		<style type='text/css'>img#wpstats{display:none}</style><style type="text/css">
	.hero-background:empty { background-image: linear-gradient(to bottom, rgba(0,0,0,0.55) 0%,rgba(0,0,0,0) 20%), url('https://media.nbcchicago.com/2019/09/OTT-Chicago.png?resize=1440%2C415&quality=85&strip=all'); }
</style>
<link rel="preload" href="https://www.nbcchicago.com/wp-content/themes/nbc-station/client/build/media/ArthouseOwned-Black.woff2" as="font" crossorigin /><link rel="preload" href="https://www.nbcchicago.com/wp-content/themes/nbc-station/client/build/media/ArthouseOwned-Bold.woff2" as="font" crossorigin /><link rel="preload" href="https://www.nbcchicago.com/wp-content/themes/nbc-station/client/build/media/ArthouseOwned-Medium.woff2" as="font" crossorigin /><link rel="preload" href="https://www.nbcchicago.com/wp-content/themes/nbc-station/client/build/media/ArthouseOwned-Light.woff2" as="font" crossorigin /><link rel="preload" href="https://www.nbcchicago.com/wp-content/themes/nbc-station/client/build/media/Roboto-Flex.woff2" as="font" crossorigin /><script>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</script><meta property="og:site_name" content="NBC Chicago" /><meta name="google-site-verification" content="5dfu0HpcCp6t0mZm0t4jLJJpdx1XlBvJNojwurIMuIQ" /><meta property="fb:app_id" content="187516345314" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:site" content="@nbcchicago" /><meta name="twitter:creator" content="@nbcchicago" /><meta property="og:type" content="article" /><meta property="article:opinion" content="false" /><meta property="article:content_tier" content="free" /><meta name="article:publisher" content="http://www.facebook.com/nbcchicago" /><meta name="description" content="Walgreens is offering free, drive-thru COVID-19 testing at various locations across the Chicago area, as more businesses and venues require negative results for..." /><meta property="og:description" content="Walgreens is offering free, drive-thru COVID-19 testing at various locations across the Chicago area, as more businesses and venues require negative results for entry." /><meta name="twitter:description" content="Walgreens is offering free, drive-thru COVID-19 testing at various locations across the Chicago area, as more businesses and venues require negative results for entry." /><meta property="og:title" content="Where to Find Free Drive-Thru Walgreens COVID Testing Near Chicago" /><meta name="twitter:title" content="Where to Find Free Drive-Thru Walgreens COVID Testing Near Chicago" /><meta name="keywords" content="Chicago Coronavirus, chicago covid, covid testing, WALGREENS, walgreens covid testing" /><meta property="og:url" content="https://www.nbcchicago.com/news/local/where-to-find-free-drive-thru-walgreens-covid-testing-near-chicago/2609969/" /><meta name="twitter:url" content="https://www.nbcchicago.com/news/local/where-to-find-free-drive-thru-walgreens-covid-testing-near-chicago/2609969/" /><meta name="sailthru.title" content="Where to Find Free Drive-Thru Walgreens COVID Testing Near Chicago" /><meta name="sailthru.description" content="Walgreens is offering free, drive-thru COVID-19 testing at various locations across the Chicago area, as more businesses and venues require negative results for..." /><meta name="sailthru.tags" content="Chicago Coronavirus, chicago covid, covid testing, WALGREENS, walgreens covid testing" /><meta name="sailthru.tags" content="Chicago Coronavirus, chicago covid, covid testing, WALGREENS, walgreens covid testing" /><meta name="sailthru.type" content="article" /><meta name="sailthru.date" content="2021-09-10T18:54:17+00:00" /><meta property="og:image:width" content="1024" /><meta property="og:image:height" content="675" /><meta property="og:image" content="https://media.nbcchicago.com/2021/09/GettyImages-1231428632.jpg?quality=85&#038;strip=all&#038;resize=1024%2C675" /><meta name="twitter:image" content="https://media.nbcchicago.com/2021/09/GettyImages-1231428632.jpg?quality=85&#038;strip=all&#038;resize=1024%2C675" /><meta name="taboola_lead" content="video" /><script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"NewsArticle","mainEntityOfPage":"https:\/\/www.nbcchicago.com\/news\/local\/where-to-find-free-drive-thru-walgreens-covid-testing-near-chicago\/2609969\/","headline":"Where to Find Free Drive-Thru Walgreens COVID Testing Near Chicago","datePublished":"2021-09-10T18:54:17","dateModified":"2021-09-10T18:54:58","description":"Walgreens is offering free, drive-thru COVID-19 testing at various locations across the Chicago area, as more businesses and venues require negative results for\u2026","speakable":{"@type":"SpeakableSpecification","cssSelector":[".article-headline",".article-subtitle"]},"keywords":"Chicago Coronavirus, chicago covid, covid testing, WALGREENS, walgreens covid testing","publisher":{"@type":"Organization","name":"NBC Chicago","logo":{"@type":"ImageObject","height":60,"url":"https:\/\/media.nbcchicago.com\/wp-content\/uploads\/2019\/09\/light_amp_wmaq.png","width":160}},"image":{"@type":"ImageObject","height":675,"url":"https:\/\/media.nbcchicago.com\/2021\/09\/GettyImages-1231428632.jpg?quality=85&strip=all&resize=1024%2C675","width":1024},"video":{"@type":"VideoObject","contentUrl":"https:\/\/www.nbcchicago.com\/news\/local\/where-to-find-free-drive-thru-walgreens-covid-testing-near-chicago\/2609969\/","description":"Walgreens is offering free, drive-thru COVID-19 testing at various locations across the Chicago area, as more businesses and venues require negative results for entry.","duration":"PT45S","name":"Where to Find Free Drive-Thru Walgreens COVID Testing Near Chicago","thumbnailUrl":"https:\/\/media.nbcchicago.com\/2021\/09\/GettyImages-1231428632.jpg?quality=85&strip=all&resize=1024%2C675","uploadDate":"2021-09-10T18:54:17"},"author":{"@type":"Person","name":"NBC Chicago"}}</script>							<script type='text/javascript'>
				var dfpAdUnits = {};
				var googletag = googletag || {};
				googletag.cmd = googletag.cmd || [];
				(function() {
				var gads = document.createElement('script');
				gads.async = true;
				gads.type = 'text/javascript';
				var useSSL = 'https:' == document.location.protocol;
				gads.src = (useSSL ? 'https:' : 'http:') +
				'//www.googletagservices.com/tag/js/gpt.js';
				var node = document.getElementsByTagName('script')[0];
				node.parentNode.insertBefore(gads, node);
				})();
				</script>
												<script type="text/javascript">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</script>
			<link rel="amphtml" href="https://www.nbcchicago.com/news/local/where-to-find-free-drive-thru-walgreens-covid-testing-near-chicago/2609969/?amp"><link rel="icon" href="https://media.nbcchicago.com/2019/09/cropped-NBC_Chicago.png?fit=32%2C32&#038;quality=85&#038;strip=all" sizes="32x32" />
<link rel="icon" href="https://media.nbcchicago.com/2019/09/cropped-NBC_Chicago.png?fit=192%2C192&#038;quality=85&#038;strip=all" sizes="192x192" />
<link rel="apple-touch-icon" href="https://media.nbcchicago.com/2019/09/cropped-NBC_Chicago.png?fit=180%2C180&#038;quality=85&#038;strip=all" />
<meta name="msapplication-TileImage" content="https://media.nbcchicago.com/2019/09/cropped-NBC_Chicago.png?fit=270%2C270&#038;quality=85&#038;strip=all" />
</head>

<body class="post-template-default single single-post postid-2609969 single-format-standard station-nbc wmaq has-featured-image short-hero">
	<div class="leaderboard_ad">
		<div id="div-gpt-ad-topbanner_" class=" gpt-topbanner" data-beforetext="" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'topbanner_', format: 'topbanner', targeting: {"slot":"topbanner","pos":"topbanner"} });
			</script><div id="div-gpt-ad-mobiletopbanner_" class=" gpt-mobiletopbanner" data-beforetext="" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'mobiletopbanner_', format: 'mobiletopbanner', targeting: {"slot":"mobiletopbanner","pos":"mobiletopbanner"} });
			</script>	</div>
	<div id="page" class="site" data-component="wrapper">
	
<a class="skip-link screen-reader-text" href="#content">Skip to content</a>
<header id="masthead" class="site-header" role="banner" data-component="siteHeader">
		<div class="site-header__primary">
		<div class="site-header__wrap">
							<div class="site-header__logo">
					<a href="https://www.nbcchicago.com/">
						<img
							src="https://media.nbcchicago.com/2021/04/Chicago.png?fit=486%2C120&#038;quality=85&#038;strip=all"
							alt="NBC Chicago"
							loading="lazy"
						/>
					</a>
				</div>
						<div class="site-header__nav-search">
				<div class="site-header__nav-main">
					<button class="site-header__nav-main-toggle">
						<span class="site-header__nav-main-toggle-text">Main Navigation</span>
					</button>
				</div>
				<div class="site-header__search" data-component="headerSearch">
					<button class="site-header__search-toggle">
						<span class="site-header__search-toggle-text">Search</span>
					</button>
					<div class="site-header__search-form">
						
<form class="search-form" role="search" method="get" action="https://www.nbcchicago.com/" >
	<label>
		<span class="screen-reader-text">Search for:</span>
		<input type="search" value="" name="s" placeholder="Search" />
	</label>
	<input type="submit" class="search-submit" value="Search" />
</form>
					</div>
				</div>
			</div>
			<div class="site-header__animated-section">
				<nav class="site-header__nav-sections">
					<div class="menu-primary-container"><nav id="primary-menu" class="menu"><a data-lid="Local" data-lpos="primary-menu" class=" menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent" href="/news/local/">Local</a></li>
<a data-lid="Weather" data-lpos="primary-menu" class=" menu-item menu-item-type-custom menu-item-object-custom" href="/weather/">Weather</a></li>
<a data-lid="Video" data-lpos="primary-menu" class=" menu-item menu-item-type-custom menu-item-object-custom" href="/videos/">Video</a></li>
<a data-lid="Investigations" data-lpos="primary-menu" class=" menu-item menu-item-type-taxonomy menu-item-object-category" href="/investigations/">Investigations</a></li>
<a data-lid="Entertainment" data-lpos="primary-menu" class=" menu-item menu-item-type-taxonomy menu-item-object-category" href="/entertainment/">Entertainment</a></li>
<a data-lid="Sports" data-lpos="primary-menu" class=" menu-item menu-item-type-custom menu-item-object-custom" href="/sports/">Sports</a></li>
<a data-lid="Newsletters" data-lpos="primary-menu" class=" menu-item menu-item-type-custom menu-item-object-custom" href="https://www.nbcchicago.com/newsletters/">Newsletters</a></li>
</nav></div>				</nav>
				<div class="site-header__weather-tv">
					<div
						class="site-header__local-weather"
						data-react-component="NBCWeather"
						data-view="conditions"
					>
					</div>
										<a class="site-header__live-tv" href="https://www.nbcchicago.com/live">Live TV</a>
									</div>
				<button class="site-header__mobile-share-toggle">
					<span class="text-share">Share</span>
					<span class="text-close">Close</span>
				</button>
			</div>
		</div> <!-- site-header__wrap -->
	</div> <!-- site-header__primary -->
	<div class="site-header__secondary">
		<div class="site-header__wrap">
							<div class="site-header__trending">
					<span class="site-header__trending-label">Trending</span>
											<nav class="site-header__trending-nav">
												<a data-lid="Coronavirus Live Blog" data-lpos="trending-stories-module" href="https://www.nbcchicago.com/news/coronavirus/illinois-coronavirus-updates-federal-employee-vaccine-mandate-tracking-outbreaks/2609378/" class="site-header__trending-nav-item">Coronavirus Live Blog</a>
					<a data-lid="Clear the Shelters" data-lpos="trending-stories-module" href="https://www.nbcchicago.com/cleartheshelters" class="site-header__trending-nav-item">Clear the Shelters</a>
					<a data-lid="9/11 Anniversary" data-lpos="trending-stories-module" href="/news/national-international/september-11-anniversary/" class="site-header__trending-nav-item">9/11 Anniversary</a>
					<a data-lid="Booster Shots" data-lpos="trending-stories-module" href="https://www.nbcchicago.com/news/coronavirus/covid-booster-shots-who-is-eligible-and-when-can-they-get-one-heres-what-to-know/2593160/" class="site-header__trending-nav-item">Booster Shots</a>
					<a data-lid="Coronavirus Stats" data-lpos="trending-stories-module" href="https://www.nbcchicago.com/news/local/where-illinois-stands-daily-coronavirus-numbers/2426019/" class="site-header__trending-nav-item">Coronavirus Stats</a>
					<a data-lid="NBC LX" data-lpos="trending-stories-module" href="https://www.nbcchicago.com/lx/" class="site-header__trending-nav-item">NBC LX</a>
					<a data-lid="Race in Chicago" data-lpos="trending-stories-module" href="https://www.nbcchicago.com/race-in-chicago/" class="site-header__trending-nav-item">Race in Chicago</a>
					<a data-lid="Reopening Illinois" data-lpos="trending-stories-module" href="https://www.nbcchicago.com/reopening-illinois/" class="site-header__trending-nav-item">Reopening Illinois</a>
					<a data-lid="Making a Difference Awards" data-lpos="trending-stories-module" href="https://www.nbcchicago.com/news/local/making-a-difference/making-a-difference-awards-2/2300429/" class="site-header__trending-nav-item">Making a Difference Awards</a>
		
							</nav>
										<div class="site-header__trending-toggle">
						<button class="trending-toggle"><span class="screen-reader-text">Expand</span></button>
					</div>
				</div>

				
<div class="site-header__alerts">
	<div
		class="site-header__weather "
		data-react-component="NBCWeather"
		data-view="alerts"
		data-alert-singular="Weather Alert"
		data-alert-plural="Weather Alerts"
		data-zip-code="60601">
	</div>
	</div> <!-- site-header__wrap -->
					</div> <!-- site-header__secondary -->
	</div>
</header>
	<div id="content" class="site-content " data-component="formsContainer">
		<div id="primary" class="content-area">
			<main id="main" class="site-main">
				<article id="post-2609969" data-component="article">

	<div
			id="template-hero"
		class="template-hero "
		data-component="templateHero"
	>
			<div class="hero-background"></div>
	
	
	
					
	
	
	
	
	
	
	</div>
		<div class="section-content--header below-hero">
		<div class="article-eyebrow__container">
	<div class="article-eyebrow__wrap">
									<a class="article-eyebrow" href="https://www.nbcchicago.com/tag/walgreens/">WALGREENS</a>						</div>
</div>
<div class="article-header--wrap ">
	<h1 class="article-headline">
		Where to Find Free Drive-Thru Walgreens COVID Testing Near Chicago	</h1>
				
<div class="article-meta" data-component="articleMeta">
	<h4 class="article-byline">
		
							<span class="time-wrap">
				<time class="entry-date published" datetime="2021-09-10T23:54:17-05:00">Published 1 hour ago</time>					<span class="meta-dot">&bull;</span>
				<time class="entry-date updated" datetime="2021-09-10T18:54:58-05:00">Updated 1 hour ago</time>			</span>
			</h4>
	<div
	class="share-buttons"
	data-component="sharingBar"
>
			<a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.nbcchicago.com%2Fnews%2Flocal%2Fwhere-to-find-free-drive-thru-walgreens-covid-testing-near-chicago%2F2609969%2F&#038;Where%20to%20Find%20Free%20Drive-Thru%20Walgreens%20COVID%20Testing%20Near%20Chicago?_osource=db_npd_nbc_wmaq_fb_shr" data-service="facebook" target="_blank">
			<span class="icon icon-facebook-f"></span>
		</a>
	
			<a href="https://twitter.com/intent/tweet?text=Where%20to%20Find%20Free%20Drive-Thru%20Walgreens%20COVID%20Testing%20Near%20Chicago&#038;url=https%3A%2F%2Fwww.nbcchicago.com%2Fnews%2Flocal%2Fwhere-to-find-free-drive-thru-walgreens-covid-testing-near-chicago%2F2609969%2F?_osource=db_npd_nbc_wmaq_twt_shr" data-service="twitter" target="_blank">
			<span class="icon icon-twitter"></span>
		</a>
	
			<a href="mailto:?body=Where%20to%20Find%20Free%20Drive-Thru%20Walgreens%20COVID%20Testing%20Near%20Chicago%0D%0A%0D%0Ahttps%3A%2F%2Fwww.nbcchicago.com%2Fnews%2Flocal%2Fwhere-to-find-free-drive-thru-walgreens-covid-testing-near-chicago%2F2609969%2F?_osource=db_npd_nbc_wmaq_eml_shr" data-service="email" target="_blank">
			<span class="icon icon-envelope"></span>
		</a>
	
	</div>
</div>
		</div>
	</div>
		<div class="section-content--full below-hero">
		<div class="section-content--primary">
			<div class="article-content--wrap">
				<div class="video-flyout" data-component="videoFlyout">
	<figure class="article-featured-media video-lead">
		<div
			data-react-component="VideoPlayer"
		data-meta="{&quot;amp_status&quot;:&quot;&quot;,&quot;spay_email&quot;:&quot;&quot;,&quot;syndicated_id&quot;:&quot;1:1:6437244&quot;,&quot;should_nationalize&quot;:false,&quot;nbc_first_published_date&quot;:&quot;&quot;,&quot;nbc_prevent_modified_update&quot;:false,&quot;nbc_linkout_title&quot;:&quot;&quot;,&quot;nbc_linkout_url&quot;:&quot;&quot;,&quot;nbc_linkout_excerpt_link&quot;:&quot;&quot;,&quot;nbc_primary_category_id&quot;:207698,&quot;nbc_primary_tag_id&quot;:385895,&quot;nbc_social_page_title&quot;:&quot;&quot;,&quot;nbc_page_title&quot;:&quot;&quot;,&quot;nbc_seo_description&quot;:&quot;&quot;,&quot;nbc_social_description&quot;:&quot;&quot;,&quot;nbc_national_headline&quot;:&quot;&quot;,&quot;entities&quot;:&quot;&quot;,&quot;nbc_canonical_market&quot;:&quot;1&quot;,&quot;nbc_canonical_url&quot;:&quot;&quot;,&quot;nbc_hide_from_recirculation&quot;:&quot;&quot;,&quot;nbc_hide_from_search&quot;:&quot;&quot;,&quot;nbc_syndication_category&quot;:&quot;1:1:207698&quot;,&quot;nbc_national_collections&quot;:[],&quot;nopreroll&quot;:false,&quot;video_copyright&quot;:&quot;NBCUniversal Media, LLC&quot;,&quot;sst_source_id&quot;:&quot;&quot;,&quot;nbc_disable_legacy_embeds&quot;:false,&quot;nbc_feed_loader_prevent_updates&quot;:&quot;&quot;,&quot;post_video_prompt&quot;:&quot;&quot;,&quot;nbc_checkout_experience_enabled&quot;:false,&quot;desktopFlashPid&quot;:&quot;&quot;,&quot;mpx_dfxp_url&quot;:&quot;&quot;,&quot;mp4_url&quot;:&quot;http:\/\/nbclim-download.edgesuite.net\/Prod\/NBCU_LM_VMS\/416\/47\/DIT_NAT_TOS_NEWS_BIDEN_SCHOOL_TESTING_090921_JB2__923881.mp4&quot;,&quot;mpx_download_pid&quot;:&quot;9_tMaTUZavIq&quot;,&quot;mpx_download_pid_high&quot;:&quot;kZpSQCTCWivA&quot;,&quot;mpx_high_id&quot;:&quot;&quot;,&quot;mpx_high_url&quot;:&quot;&quot;,&quot;mpx_is_livestream&quot;:&quot;&quot;,&quot;mpx_m3upid&quot;:&quot;&quot;,&quot;mpx_pid&quot;:&quot;cZDKfmaSLoqB&quot;,&quot;mpx_thumbnail_url&quot;:&quot;https:\/\/media.nbcchicago.com\/2021\/09\/GettyImages-1339101642.jpg?quality=85&amp;strip=all&amp;resize=850%2C478&quot;,&quot;pid_streaming_web_high&quot;:&quot;xcF6uINO6IoY&quot;,&quot;pid_streaming_web_medium&quot;:&quot;cZDKfmaSLoqB&quot;,&quot;subtitle&quot;:&quot;&quot;,&quot;dfxp_url&quot;:&quot;&quot;,&quot;video_call_letter&quot;:&quot;NBCU LM VMS&quot;,&quot;video_captions&quot;:&quot;&quot;,&quot;video_id&quot;:&quot;1943907907882_451&quot;,&quot;video_length&quot;:&quot;45078&quot;,&quot;video_provider&quot;:&quot;mpx&quot;,&quot;short_video_excerpt&quot;:&quot;&quot;,&quot;mpx_download_pid_mobile_low&quot;:&quot;&quot;,&quot;pid_streaming_web_mobile_low&quot;:&quot;&quot;,&quot;alleypack_schedule_unpublish&quot;:&quot;&quot;,&quot;feed_remote_id&quot;:&quot;mpx_1943907907882&quot;,&quot;feed_thumbnail_url&quot;:&quot;&quot;}"
	data-livestream="false"
	data-title="Biden to Call on Regular COVID-19 Testing at Schools"
	data-vidcid="1:6:2608466"
	data-vidurl="https://www.nbcchicago.com/news/local/biden-to-call-on-regular-covid-19-testing-at-schools/2608466/"
			data-islead="true"
		data-catnames="{&quot;196993&quot;:&quot;News&quot;,&quot;247209&quot;:&quot;Coronavirus Pandemic&quot;,&quot;359&quot;:&quot;Local&quot;}"
	data-tagnames="{&quot;235279&quot;:&quot;Chicago Coronavirus&quot;,&quot;303674&quot;:&quot;chicago covid&quot;,&quot;305330&quot;:&quot;covid testing&quot;,&quot;242454&quot;:&quot;COVID-19&quot;,&quot;282270&quot;:&quot;covid-19 testing&quot;,&quot;2046&quot;:&quot;Joe Biden&quot;,&quot;385895&quot;:&quot;Schools and COVID&quot;,&quot;17801&quot;:&quot;WALGREENS&quot;,&quot;297084&quot;:&quot;walgreens covid testing&quot;}"
	data-customdata="{}"
			data-autoplay="true"
				data-cplay="true"
	></div>
			<figcaption>
									<cite>NBCUniversal Media, LLC</cite>
				
															<div
							class="caption"
							data-react-component="NBCTruncate"
							data-maxlines="2"
							data-maxlinesmobile="4"
							data-readmore="Read more"
							data-text="&lt;p&gt;President Joe Biden will call on schools to set up regular COVID-19 testing for students, teachers and staff, according to an administration official.&lt;/p&gt;
"
							data-ellipsis="false">
						</div>
												</figcaption>
						<button class="video-flyout__dismiss"><span class="icon icon-times"></span></button>
			</figure>
</div>
				<div class="article-content rich-text">
					
					
<p>Walgreens is offering free, drive-thru COVID-19 testing at various locations across the Chicago area, as more businesses and venues require negative results for entry. </p>

<p>For people ages 3 and up, Walgreens provides contactless coronavirus testing at select locations around the city. </p>
<div class="mobile-app-promotion">
	
<div class="wp-block-nbc-localized-block">
<blockquote class="featured-text">
	Our redesigned local news and weather app is live! Download it for <a href="https://apps.apple.com/us/app/nbc-5-chicago/id331802255">iOS</a> or <a href="https://play.google.com/store/apps/details?id=com.nbcuni.nbcots.nbcchicago.android&amp;hl=en_US&amp;gl=US">Android</a> <em>—</em> and sign up for alerts. </blockquote>
</div>
</div>

<p>Here's how the process works, according to the company's website: </p>

<ol><li>Complete a questionnaire </li><li>Choose a location and time for the test </li><li>Go to the location and stay in the vehicle with the window rolled up </li><li>Show a confirmation email, valid ID and insurance card or voucher </li><li>Perform a nasal swab yourself. Patients ages 3 to 18 will need a parent present while they self-administer the COVID test </li><li>View test results on PWNHealth </li></ol>

<p>To see a list of drive-thru locations nearby, click <a href="https://www.walgreens.com/findcare/covid19/testing?ban=covid_vanity_testing">here </a>and search your ZIP code. </p>
<div class="recirc-module">
	<h3 class="recirc__heading">Local</h3>
	<p class="recirc__subheading"></p>
					<div class="recirc__post">
			<div class="post__wrap">
				<div class="post__image-wrapper">
											<a data-lpos="inline-recirc-module" data-lid="Why Kris Bryant Return With Giants Could Be New Normal for Cubs" href="https://www.nbcchicago.com/news/sports/nbcsports/why-kris-bryant-return-with-giants-could-be-new-normal-for-cubs/2610021/">
							<img class="post__image" srcset="https://media.nbcchicago.com/2021/09/Kris-Bryant-San-Francisco-Giants-USATSI_16720096.jpg?quality=85&amp;strip=all&amp;resize=200%2C113 200w, https://media.nbcchicago.com/2021/09/Kris-Bryant-San-Francisco-Giants-USATSI_16720096.jpg?quality=85&amp;strip=all&amp;resize=400%2C225 400w, https://media.nbcchicago.com/2021/09/Kris-Bryant-San-Francisco-Giants-USATSI_16720096.jpg?quality=85&amp;strip=all&amp;resize=600%2C338 600w, " src="https://media.nbcchicago.com/2021/09/Kris-Bryant-San-Francisco-Giants-USATSI_16720096.jpg?quality=85&#038;strip=all&#038;resize=600%2C338" alt="" sizes="200px" loading="lazy" />
						</a>

						
															</div>

				<div class="post__text">
					<div class="post__meta">
													<a data-lpos="inline-recirc-module" data-lid="Kris Bryant" class="post__tag" href="https://www.nbcchicago.com/tag/kris-bryant/">Kris Bryant</a>
																			<span class="post__date post__date--has-category">
								1 hour ago							</span>
											</div>

											<h3 class="post__title">
							<a data-lpos="inline-recirc-module" data-lid="Why Kris Bryant Return With Giants Could Be New Normal for Cubs" class="post__title--link" href="https://www.nbcchicago.com/news/sports/nbcsports/why-kris-bryant-return-with-giants-could-be-new-normal-for-cubs/2610021/">
								Why Kris Bryant Return With Giants Could Be New Normal for Cubs							</a>
						</h3>
									</div>
			</div>
		</div>
					<div class="recirc__post">
			<div class="post__wrap">
				<div class="post__image-wrapper">
											<a data-lpos="inline-recirc-module" data-lid="Exclusive: Chicago&#039;s Former Top Aide On Public Safety Speaks Out" href="https://www.nbcchicago.com/news/local/exclusive-chicagos-former-top-aide-on-public-safety-speaks-out/2609946/">
							<img class="post__image" srcset="https://media.nbcchicago.com/2021/09/susan-lee.png?resize=200%2C113&amp;quality=85&amp;strip=all 200w, https://media.nbcchicago.com/2021/09/susan-lee.png?resize=400%2C225&amp;quality=85&amp;strip=all 400w, https://media.nbcchicago.com/2021/09/susan-lee.png?resize=600%2C338&amp;quality=85&amp;strip=all 600w, " src="https://media.nbcchicago.com/2021/09/susan-lee.png?resize=600%2C338&#038;quality=85&#038;strip=all" alt="" sizes="200px" loading="lazy" />
						</a>

													<span class="format-icon format-icon--video"></span>
						
															</div>

				<div class="post__text">
					<div class="post__meta">
													<a data-lpos="inline-recirc-module" data-lid="Chicago Shootings" class="post__tag" href="https://www.nbcchicago.com/tag/chicago-shootings/">Chicago Shootings</a>
																			<span class="post__date post__date--has-category">
								2 hours ago							</span>
											</div>

											<h3 class="post__title">
							<a data-lpos="inline-recirc-module" data-lid="Exclusive: Chicago&#039;s Former Top Aide On Public Safety Speaks Out" class="post__title--link" href="https://www.nbcchicago.com/news/local/exclusive-chicagos-former-top-aide-on-public-safety-speaks-out/2609946/">
								Exclusive: Chicago&#039;s Former Top Aide On Public Safety Speaks Out							</a>
						</h3>
									</div>
			</div>
		</div>
	</div>

<p>Though test results can be returned within varying times depending on the laboratory, most are returned with 24 to 48 hours. </p>

<p>For both the Rapid Diagnostic Test and the Rapid Antigen Test, test results return between one to 24 hours, according to Walgreens. </p>

<p>Walgreens noted pharmacies do not provide walk-in COVID testing. Rather, all testing is performed from the vehicle window. </p>

<p>For more testing locations throughout Illinois, click <a href="https://dph.illinois.gov/testing">here</a>. </p>

<p>Those living within city perimeters can use options from the Chicago Department of Public Health's website:</p>

<ul><li><strong>At-home:</strong> Some private companies will send tests directly to your home. The following tests have been authorized by the FDA. They include: a nose swab from <a href="https://www.pixel.labcorp.com/covid-19?gclid=EAIaIQobChMIo7Hl2Jz97AIVPvDjBx3AZAb3EAAYASAAEgJoyPD_BwE">Pixel by LabCorp</a> ,&nbsp;<a rel="noreferrer noopener" href="https://www.everlywell.com/products/covid-19-test/" target="_blank">everywell</a> or <a rel="noreferrer noopener" href="https://www.letsgetchecked.com/us/en/home-coronavirus-test/" target="_blank">LetsGetChecked</a>&nbsp;and saliva options like <a rel="noreferrer noopener" href="https://www.vaulthealth.com/covid" target="_blank">Vault</a> or <a rel="noreferrer noopener" href="https://vitagene.com/products/covid-19-saliva-test-kit/" target="_blank">Vitagene</a>. "This is not an exhaustive list and CDPH does not necessary recommend any specific private company," the department's website reads.</li><li><strong>Your health care provider</strong>: According to CDPH, this is the best route for testing "because your health care provider is familiar with your medical history and can provide counselling that helps you understand exactly what your test result means."</li><li><strong>Community health centers: </strong>According to CDPH, there are roughly 165 community health centers throughout Chicago. Find one near you at <a rel="noreferrer noopener" href="https://findahealthcenter.hrsa.gov/" target="_blank">hrsa.gov</a>. "No patient will be turned away because of inability to pay. Community health centers provide services regardless of patients’ immigration status and charge for services on a sliding fee scale," CDPH states.</li><li><strong>Testing Map:</strong> Use the&nbsp;<a href="https://www.chicago.gov/city/en/sites/covid-19/home/covid-testing.html">City of Chicago’s interactive testing map</a>&nbsp;to find a testing site near you. According to CDPH, the map is updated frequently, but different testing sites might have different requirements. "We recommend calling in advance or checking online first," the department states.</li><li><strong>City of Chicago testing sites:&nbsp;</strong>Chicago offers several <a rel="noreferrer noopener" href="https://www.chicago.gov/city/en/sites/covid-19/home/testing.html" target="_blank">community-based testing sites</a>&nbsp;at no cost. To pre-register and schedule an appointment, click&nbsp;<a rel="noreferrer noopener" href="https://chicago.curativeinc.com/welcome" target="_blank">here</a>.&nbsp;</li><li><strong>Traveler testing:</strong>&nbsp;PCR testing is available at O'Hare and Midway airports for travelers and airport/CDA employees, but it does cost money. The Rapid Antigen Test is $120, with patients receiving results in about 20 minutes. The PCR Test is $145, with results in about 24-72 hours. Anyone getting a test at the airport will need to show proof of flying (within 72 hours before their flight or five days after) or proof of airport employment.</li></ul>

									</div>
								<div class="article-footer">
			<div class="article-tags">
	<h4 class="article-tags__heading">This article tagged under:</h4>
	<a class="article-tags__tag" href="https://www.nbcchicago.com/tag/walgreens/">WALGREENS</a><a class="article-tags__tag" href="https://www.nbcchicago.com/tag/chicago-coronavirus/">Chicago Coronavirus</a><a class="article-tags__tag" href="https://www.nbcchicago.com/tag/chicago-covid/">chicago covid</a><a class="article-tags__tag" href="https://www.nbcchicago.com/tag/covid-testing/">covid testing</a><a class="article-tags__tag" href="https://www.nbcchicago.com/tag/walgreens-covid-testing/">walgreens covid testing</a></div>
			<div
	class="share-buttons"
	data-component="sharingBar"
>
			<a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.nbcchicago.com%2Fnews%2Flocal%2Fwhere-to-find-free-drive-thru-walgreens-covid-testing-near-chicago%2F2609969%2F&#038;Where%20to%20Find%20Free%20Drive-Thru%20Walgreens%20COVID%20Testing%20Near%20Chicago?_osource=db_npd_nbc_wmaq_fb_shr" data-service="facebook" target="_blank">
			<span class="icon icon-facebook-f"></span>
		</a>
	
			<a href="https://twitter.com/intent/tweet?text=Where%20to%20Find%20Free%20Drive-Thru%20Walgreens%20COVID%20Testing%20Near%20Chicago&#038;url=https%3A%2F%2Fwww.nbcchicago.com%2Fnews%2Flocal%2Fwhere-to-find-free-drive-thru-walgreens-covid-testing-near-chicago%2F2609969%2F?_osource=db_npd_nbc_wmaq_twt_shr" data-service="twitter" target="_blank">
			<span class="icon icon-twitter"></span>
		</a>
	
			<a href="mailto:?body=Where%20to%20Find%20Free%20Drive-Thru%20Walgreens%20COVID%20Testing%20Near%20Chicago%0D%0A%0D%0Ahttps%3A%2F%2Fwww.nbcchicago.com%2Fnews%2Flocal%2Fwhere-to-find-free-drive-thru-walgreens-covid-testing-near-chicago%2F2609969%2F?_osource=db_npd_nbc_wmaq_eml_shr" data-service="email" target="_blank">
			<span class="icon icon-envelope"></span>
		</a>
	
			<a href="#" data-service="comments">
			<span class="icon icon-comment-alt"></span>
		</a>
	</div>
		</div>
					<div id="div-gpt-ad-mobilemultibox_belowarticle" class="widget_ad_layers_ad_widget gpt-mobilemultibox" data-beforetext="" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'mobilemultibox_belowarticle', format: 'mobilemultibox', targeting: {"slot":"mobilemultibox","pos":"mobilemultibox"} });
			</script>	<div id="taboola-below-article-thumbnails"></div>

	<script type="text/javascript">
		/** scroll cookie for scroll.com **/
		if (document.cookie.indexOf("scroll0=") < 0) {
			window._taboola = window._taboola || [];
						_taboola.push({
				mode: 'thumbnails-a',
				container: 'taboola-below-article-thumbnails',
				placement: 'Below Article Thumbnails',
				target_type: 'text'
			});
					};
	</script>
		<div id="mobile-native-below-article"></div>
	<script type="text/javascript">
		var isMobile = window.matchMedia('screen and (max-width: 767px)').matches;
		/** scroll cookie for scroll.com **/
		if (document.cookie.indexOf("scroll0=") < 0 && isMobile) {
			window._taboola = window._taboola || [];
			_taboola.push({
				mode: 'thumbs-feed-03-mobile',
				container: 'mobile-native-below-article',
				placement: 'Below Article Thumbnails - Fallback',
				target_type: 'text'
			});
		};
	</script>
					</div>
		</div>
		<div class="section-content--secondary">
			<aside class="sidebar article-sidebar">
						<section id="nbc_most_popular-2" class="widget widget_nbc_most_popular"><div class="nbc-most-popular" data-react-component="MostPopular" data-title="Trending Stories" data-include-sponsored="true" data-beforetext="Presented By"></div></section><section id="ad_layers_ad_widget-2" class="widget widget_ad_layers_ad_widget"><div id="div-gpt-ad-topbox_416" class=" gpt-topbox" data-beforetext="" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'topbox_416', format: 'topbox', targeting: {"slot":"topbox","pos":"topbox"} });
			</script></section><section id="nbc_weather_widget-3" class="widget widget_nbc_weather_widget">		<div class="nbc-weather-widget">
			<div class="nbc_owned_television_stations_weather_iframe">
	<h3>Weather Forecast</h3><div data-react-component="IframeLocation" data-market-name="Chicago, IL"></div>
	<a class="weather-module__conditions" href="https://www.nbcchicago.com/weather/">
		<div data-react-component="IframeConditions" data-location="60601"></div>
	</a>
		<div class="widget_sponsor">
		<div id="div-gpt-ad-logo_weather_841" class="sponsored-ad-unit gpt-logo" data-beforetext="Presented By" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'logo_weather_841', format: 'logo', targeting: {"module":"weather","slot":"logo","pos":"logo"} });
			</script>	</div>
</div>
		</div>
		</section><section id="ad_layers_ad_widget-9" class="widget widget_ad_layers_ad_widget"><div id="div-gpt-ad-mobilemultibox_247" class=" gpt-mobilemultibox" data-beforetext="" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'mobilemultibox_247', format: 'mobilemultibox', targeting: {"slot":"mobilemultibox","pos":"mobilemultibox"} });
			</script></section><section id="nbc_civic_science-2" class="widget widget_nbc_civic_science"><div id="civsci-1526471737" class="module-civicScience" data-tgtid="e77f691f-80d7-8da4-9138-f5969b52d758"></div></section><section id="ad_layers_ad_widget-6" class="widget widget_ad_layers_ad_widget"><div id="div-gpt-ad-bottombox_212" class=" gpt-bottombox" data-beforetext="" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'bottombox_212', format: 'bottombox', targeting: {"slot":"bottombox","pos":"bottombox"} });
			</script></section><section id="ad_layers_ad_widget-12" class="widget widget_ad_layers_ad_widget"><div id="div-gpt-ad-interstitial_266" class=" gpt-interstitial" data-beforetext="" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'interstitial_266', format: 'interstitial', targeting: {"slot":"interstitial","pos":"interstitial"} });
			</script></section><section id="ad_layers_ad_widget-13" class="widget widget_ad_layers_ad_widget"><div id="div-gpt-ad-mobilebackstage_600" class=" gpt-mobilebackstage" data-beforetext="" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'mobilebackstage_600', format: 'mobilebackstage', targeting: {"slot":"mobilebackstage","pos":"mobilebackstage"} });
			</script></section><section id="nbc_newsletter-2" class="widget widget_nbc_newsletter"><div class="newsletter-widget"
				data-react-component="NewsletterWidget"
				data-title="Subscribe to our Newsletters"
				data-description="Sign up to receive breaking news alerts in your inbox."
				data-newsletter-id="WMAQ_BreakingNews"
				data-privacy-link="http://www.nbcuniversal.com/privacy/"
				data-newsletter-link=""
				data-nonce="93f6fd200a"
				></div></section>			</aside>
		</div>
	</div>
</article>

			</main>
		</div>

		
	</div><!-- #content -->
	
<footer role="contentinfo" class="site-footer">
	<div class="site-footer__wrapper">
		<div class="site-footer__identity">
							<a href="https://www.nbcchicago.com/" class="site-footer__logo">
					<img
						src="https://media.nbcchicago.com/2021/04/Chicago@3x.png?fit=486%2C120&#038;quality=85&#038;strip=all"
						alt="NBC Chicago"
						loading="lazy"
					/>
				</a>
			
			
			<ul class="site-footer__social-list">
				
									<li class="site-footer__social-list-item facebook">
						<a href="http://www.facebook.com/nbcchicago" target="_blank" rel="noopener noreferrer">
							<span class="screen-reader-text">Facebook</span>
							<span class="icon icon-facebook-f"></span>
						</a>
					</li>
				
									<li class="site-footer__social-list-item twitter">
						<a href="https://twitter.com/nbcchicago" target="_blank" rel="noopener noreferrer">
							<span class="screen-reader-text">Twitter</span>
							<span class="icon icon-twitter"></span>
						</a>
					</li>
				
									<li class="site-footer__social-list-item instagram">
						<a href="https://instagram.com/nbcchicago" target="_blank" rel="noopener noreferrer">
							<span class="screen-reader-text">Instagram</span>
							<span class="icon icon-instagram"></span>
						</a>
					</li>
							</ul>
		</div>

		<ul id="menu-footer" class="footer-menu site-footer__menu-primary"><li id="menu-item-2164663" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2164663"><a href="/investigations/submit-tip/">Submit Tips for Investigations</a></li>
<li id="menu-item-2185054" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2185054"><a href="/newsletters/">Newsletters</a></li>
<li id="menu-item-2164660" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2164660"><a href="https://www.nbcchicago.com/contact-us/">Connect With Us</a></li>
</ul><ul id="menu-secondary-footer" class="footer-menu-secondary site-footer__menu-secondary"><li id="menu-item-1970487" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1970487"><a href="https://www.nbcchicago.com/send-feedback/">Send Feedback</a></li>
<li id="menu-item-1970489" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1970489"><a href="https://www.nbcchicago.com/wmaq-employment-information/">WMAQ Employment Information</a></li>
<li id="menu-item-2361254" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2361254"><a href="https://www.nbcchicago.com/fcc-applications/">FCC Applications</a></li>
<li id="menu-item-1970488" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1970488"><a href="https://www.nbcchicago.com/terms-of-service/">Terms of Service</a></li>
<li id="menu-item-2154264" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2154264"><a target="_blank" rel="noopener noreferrer" href="https://www.nbcuniversal.com/privacy/notrtoo?brandA=Owned_Stations&#038;intake=NBC_Chicago/">Do Not Sell My Personal Information</a></li>
<li id="menu-item-1970475" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1970475"><a target="_blank" rel="noopener noreferrer" href="https://www.nbcuniversal.com/privacy/?brandA=Owned_Stations&#038;intake=NBC_Chicago/">Privacy Policy</a></li>
<li id="menu-item-1970477" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1970477"><a href="mailto:WMAQViewerMail.Advertising@nbcuni.com?subject=Advertise%20with%20Us%20HP/">Advertise with us</a></li>
<li id="menu-item-1970474" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1970474"><a href="https://publicfiles.fcc.gov/tv-profile/wmaq-tv">WMAQ Public Inspection File</a></li>
<li id="menu-item-2309227" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2309227"><a href="https://www.nbcuniversal.com/privacy/california-consumer-privacy-act?intake=NBC_Chicago">CA Notice</a></li>
<li id="menu-item-1970476" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1970476"><a href="https://info.evidon.com/pub_info/209?v=1&#038;nt=0&#038;nw=false/">AdChoices</a></li>
</ul>
				<div class="site-footer__corporate">
			
			<span class="site-footer__corporate-copyright">
				Copyright © 2021 NBCUniversal Media, LLC. All rights reserved			</span>
		</div>
	</div><!-- wrapper -->
</footer><!-- #colophon -->
</div><!-- #page -->

	<script type="text/javascript">
	(function() {
		var _sf_async_config      = window._sf_async_config = window._sf_async_config || {};
		_sf_async_config.domain   = "nbcchicago.com";
		_sf_async_config.uid      = 15527;
		_sf_async_config.sections = "local";
		_sf_async_config.authors  = "";
		_sf_async_config.title    = "Where to Find Free Drive-Thru Walgreens COVID Testing Near Chicago";
		
		var e = document.createElement('script');
		var n = document.getElementsByTagName('script')[0];
		e.type = 'text/javascript';
		e.async = true;
		e.src = '//static.chartbeat.com/js/chartbeat.js';
		n.parentNode.insertBefore(e, n);
	})();
	</script>
			<!-- Begin comScore Tag -->
		<script>
		var usPrivacyCookie = new RegExp("usprivacy=([^;]+)").exec(document.cookie),
		usPrivacy = null !== usPrivacyCookie ? unescape(usPrivacyCookie[1]) : undefined,
		csUCFR= '1YNN' === usPrivacy ? '': '0',
		_comscore = _comscore || [];
		_comscore.push({
			c1: "2",
			c2: "6035083",
			cs_ucfr: csUCFR,
		});
		(function() {
			var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
			s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
			el.parentNode.insertBefore(s, el);
		})();
		</script>
		<noscript>
			<img src="https://sb.scorecardresearch.com/p?c1=2&c2=6035083&cv=2.0&cj=1" />
		</noscript>
		<!-- End comScore Tag -->
				<script type="text/javascript">
		(function() {
			window._taboola = window._taboola || [];
			window._newsroom = window._newsroom || [];
			var loaderUrl = 'https://cdn.taboola.com/libtrc/nbcots-network/loader.js';
			const taboola_config = {};

			taboola_config[decodeURIComponent( 'article' )] = decodeURIComponent( '2609969' );
			taboola_config['url'] = document.URL;
			taboola_config['tracking'] = '_osource=taboola-recirc';
			_taboola.push(taboola_config);

			
			!function (e, f, u, i) {
				e.async = 1;
				e.src = u;
				e.id = i;
				f.parentNode.insertBefore(e, f);
			}(document.createElement('script'),
			document.getElementsByTagName('script')[0],
			loaderUrl,
			'tb_loader_script');

			!function (e, f, u) {
				e.async = 1;
				e.src = u;
				f.parentNode.insertBefore(e, f);
			}(document.createElement('script'),
			document.getElementsByTagName('script')[0],
			"\/\/c2.taboola.com\/nr\/nbcots-wmaq\/newsroom.js");
		}());
		</script>
				<div class="facebook-comments">
			<button class="facebook-comments__close"><span class="icon icon-chevron-left"></span> Back to Article</button>
			<div class="fb-comments" data-href="https://www.nbcchicago.com/news/local/where-to-find-free-drive-thru-walgreens-covid-testing-near-chicago/2609969/" data-width="100%"></div>
		</div>
		<div class="flyout-nav" data-component="flyoutNav">
	<button class="flyout-nav__close"><span class="icon icon-times"></span> <span class="screen-reader-text">Close Menu</span></button>
	<div class="flyout-nav__logo">
		<a href="https://www.nbcchicago.com/">
					<img
						src="https://media.nbcchicago.com/2021/04/Chicago@3x.png?fit=486%2C120&#038;quality=85&#038;strip=all"
						alt="NBC Chicago"
					/>
		</a>
	</div>
	<div class="flyout-nav__search">
<form class="search-form" role="search" method="get" action="https://www.nbcchicago.com/" >
	<label>
		<span class="screen-reader-text">Search for:</span>
		<input type="search" value="" name="s" placeholder="Search" />
	</label>
	<input type="submit" class="search-submit" value="Search" />
</form>
</div>
	<div class="flyout-nav__menu">
		<div class="flyout-nav__menu--upper">
							<a data-lid="Coronavirus Pandemic" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/news/coronavirus/">
					Coronavirus Pandemic				</a>
							<a data-lid="Local" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/news/local/">
					Local				</a>
							<a data-lid="Weather" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/weather/">
					Weather				</a>
							<a data-lid="Weather Alerts" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/weather/severe-weather-alerts/">
					Weather Alerts				</a>
							<a data-lid="School Closings" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="http://www.emergencyclosingcenter.com/">
					School Closings				</a>
							<a data-lid="Investigations" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/investigations/">
					Investigations				</a>
							<a data-lid="NBC 5 Responds" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/consumer/">
					NBC 5 Responds				</a>
							<a data-lid="Entertainment" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/entertainment/">
					Entertainment				</a>
							<a data-lid="Traffic" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/traffic/">
					Traffic				</a>
							<a data-lid="Sports" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/news/sports/">
					Sports				</a>
							<a data-lid="Chicago Baseball" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/news/sports/chicago-baseball/">
					Chicago Baseball				</a>
							<a data-lid="Chicago Football" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/news/sports/chicago-football/">
					Chicago Football				</a>
							<a data-lid="Chicago Hockey" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/news/sports/chicago-hockey/">
					Chicago Hockey				</a>
							<a data-lid="Health" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/news/health/">
					Health				</a>
							<a data-lid="U.S. &amp; World" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/news/national-international/">
					U.S. &amp; World				</a>
							<a data-lid="NBCLX" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/lx/">
					NBCLX				</a>
							<a data-lid="Making A Difference" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/news/local/making-a-difference/">
					Making A Difference				</a>
							<a data-lid="Chicago Today" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/entertainment/chicago-today/">
					Chicago Today				</a>
					</div>
		<div class="flyout-nav__menu--lower">
							<a data-lid="Submit a Consumer Complaint" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/consumer-form/">
					Submit a Consumer Complaint				</a>
							<a data-lid="Submit Photos and Video" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="https://www.nbcchicago.com/ugc/">
					Submit Photos and Video				</a>
							<a data-lid="Contests" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/on-air/contests/">
					Contests				</a>
							<a data-lid="Newsletters" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="https://www.nbcchicago.com/newsletters/">
					Newsletters				</a>
							<a data-lid="Our Apps" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/products/">
					Our Apps				</a>
					</div>
	</div>
	<div class="flyout-nav__social">
		<h4 class="flyout-nav__social-heading">Follow Us</h4>
		<ul class="flyout-nav__social-list">
			
							<li class="site-footer__social-list-item facebook" rel="noopener noreferrer">
					<a href="http://www.facebook.com/nbcchicago" target="_blank">
						<span class="screen-reader-text">Facebook</span>
						<span class="icon icon-facebook-f"></span>
					</a>
				</li>
			
							<li class="site-footer__social-list-item twitter" rel="noopener noreferrer">
					<a href="https://twitter.com/nbcchicago" target="_blank">
						<span class="screen-reader-text">Twitter</span>
						<span class="icon icon-twitter"></span>
					</a>
				</li>
			
							<li class="site-footer__social-list-item instagram" rel="noopener noreferrer">
					<a href="https://instagram.com/nbcchicago" target="_blank">
						<span class="screen-reader-text">Instagram</span>
						<span class="icon icon-instagram"></span>
					</a>
				</li>
					</ul>
	</div>
</div>
<a class="flyout-contact-button" data-lid="Contact Us" data-lpos="hamburger-menu"
			href="/contact-us"
	>
	Contact Us</a>
<link rel='stylesheet' id='all-css-0' href='https://www.nbcchicago.com/_static/??-eJydzktOAzEMBuAL0TwmjyYLxA0QO5YocRwaKY/RxEPV2zPtCaArL/z7+82v6wlGJ+zE6YINJ+8RTpMCldE51HLfxL3UxGFO3sakj7HuNWxsERjO2eez1y5LpxbnNGulsyP4wv8Jd7zOikS4fZb0jcTAWFQpRYd+sSBSiC4/recxDpmlpHLUGqwBsC54aWN63qy3sdN7+GEYvYwWQAStjHAojoa/so8JD3Ct4Ybb12zHs5f77Vt7lVbJxZvFml98iJej' type='text/css' media='all' />
<script src='https://www.nbcchicago.com/wp-content/mu-plugins/jetpack-9.4/_inc/build/photon/photon.min.js?ver=20191001' id='jetpack-photon-js'></script>
<script src='https://www.nbcchicago.com/wp-includes/js/dist/vendor/wp-polyfill.min.js?ver=7.4.4' id='wp-polyfill-js'></script>
<script id='wp-polyfill-js-after'>
( 'fetch' in window ) || document.write( '<script src="https://www.nbcchicago.com/wp-includes/js/dist/vendor/wp-polyfill-fetch.min.js?ver=3.0.0"></scr' + 'ipt>' );( document.contains ) || document.write( '<script src="https://www.nbcchicago.com/wp-includes/js/dist/vendor/wp-polyfill-node-contains.min.js?ver=3.42.0"></scr' + 'ipt>' );( window.DOMRect ) || document.write( '<script src="https://www.nbcchicago.com/wp-includes/js/dist/vendor/wp-polyfill-dom-rect.min.js?ver=3.42.0"></scr' + 'ipt>' );( window.URL && window.URL.prototype && window.URLSearchParams ) || document.write( '<script src="https://www.nbcchicago.com/wp-includes/js/dist/vendor/wp-polyfill-url.min.js?ver=3.6.4"></scr' + 'ipt>' );( window.FormData && window.FormData.prototype.keys ) || document.write( '<script src="https://www.nbcchicago.com/wp-includes/js/dist/vendor/wp-polyfill-formdata.min.js?ver=3.0.12"></scr' + 'ipt>' );( Element.prototype.matches && Element.prototype.closest ) || document.write( '<script src="https://www.nbcchicago.com/wp-includes/js/dist/vendor/wp-polyfill-element-closest.min.js?ver=2.0.2"></scr' + 'ipt>' );
</script>
<script src='https://www.nbcchicago.com/wp-includes/js/dist/i18n.min.js?ver=4ab02c8fd541b8cfb8952fe260d21f16' id='wp-i18n-js'></script>
<script src='https://www.nbcchicago.com/wp-includes/js/dist/vendor/lodash.min.js?ver=4.17.21' id='lodash-js'></script>
<script id='lodash-js-after'>
window.lodash = _.noConflict();
</script>
<script src='https://www.nbcchicago.com/wp-includes/js/dist/url.min.js?ver=d80b474ffb72c3b6933165cc1b3419f6' id='wp-url-js'></script>
<script src='https://www.nbcchicago.com/wp-includes/js/dist/hooks.min.js?ver=63769290dead574c40a54748f22ada71' id='wp-hooks-js'></script>
<script id='wp-api-fetch-js-translations'>
( function( domain, translations ) {
	var localeData = translations.locale_data[ domain ] || translations.locale_data.messages;
	localeData[""].domain = domain;
	wp.i18n.setLocaleData( localeData, domain );
} )( "default", { "locale_data": { "messages": { "": {} } } } );
</script>
<script src='https://www.nbcchicago.com/wp-includes/js/dist/api-fetch.min.js?ver=0bb73d10eeea78a4d642cdd686ca7f59' id='wp-api-fetch-js'></script>
<script id='wp-api-fetch-js-after'>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</script>
<script src='https://www.nbcchicago.com/wp-content/themes/nbc-station/client/build/js/common.b3ceb8b7341a4a0c1304.bundle.min.js?ver=1.0.2' id='nbc-common-js-js'></script>
<script async src='https://www.nbcchicago.com/wp-content/themes/nbc-station/client/build/js/weatherConditions.87a2ab5dafb347c6e53b.bundle.min.js?ver=1.0.2' id='nbc-weather-conditions-js'></script>
<script async src='https://www.nbcchicago.com/wp-content/themes/nbc-station/client/build/js/global.bf7b5a0b45df529f8361.bundle.min.js?ver=1.0.2' id='nbc-global-js-js'></script>
<script async src='https://www.nbcchicago.com/wp-content/themes/nbc-station/client/build/js/article.53b0ab3116d636de915e.bundle.min.js?ver=1.0.2' id='nbc-article-js-js'></script>
<script src='https://www.nbcchicago.com/wp-content/themes/nbc-station/client/build/js/analytics.37a755a6d88530f7c27a.bundle.min.js?ver=1.0.2' id='nbc-analytics-js-js'></script>
<script src='https://ak.sail-horizon.com/spm/spm.v1.min.js?ver=1.0.0' id='nbc-sailthru-js'></script>
<script id='nbc-sailthru-js-after'>
if ("undefined" !== typeof Sailthru) { Sailthru.init({"customerId":"757cc89c051f4552fa5708e6f3b93a01"}); }
</script>
<script src='https://www.nbcchicago.com/wp-content/themes/nbc-station/static/js/zepto.min.js?ver=1.0.2' id='zepto-js'></script>
<script src='https://www.nbcchicago.com/wp-content/themes/nbc-station/static/js/player.6.1.3.js?ver=1.0.2' id='pdk-js'></script>
<script src='https://www.nbcchicago.com/wp-content/themes/nbc-station/client/build/js/videoPlayer.7b5017f07999a106edc4.bundle.min.js?ver=1.0.2' id='nbc-video-player-js'></script>
<script src='https://native.sharethrough.com/assets/sfp.js?ver=5.5.6' id='sharethrough-js'></script>
<script async src='https://www.nbcchicago.com/wp-content/themes/nbc-station/client/build/js/flyoutNav.276edabb7c307347f121.bundle.min.js?ver=1.0.2' id='nbc-flyout-nav-js'></script>
<script src='https://www.nbcchicago.com/wp-content/themes/nbc-station/client/build/js/articleContent.002368ae3a0d6363e579.bundle.min.js?ver=1.0.2' id='nbc-article-content-js'></script>
<script defer src='https://js-sec.indexww.com/ht/p/186439-32299936421738.js?ver=1.0.2' id='nbc-index-exchange-js'></script>
<script src='https://www.nbcchicago.com/wp-includes/js/wp-embed.min.js?ver=5.5.6' id='wp-embed-js'></script>
<script src='https://www.nbcchicago.com/wp-content/themes/nbc-station/client/build/js/mostPopular.612ce2b8680af2464a4c.bundle.min.js?ver=1.0.2' id='nbc-most-popular-js'></script>
<script src='https://www.nbcchicago.com/wp-content/themes/nbc-station/client/build/js/civicScience.4db1dfb9fe92d553e9e3.bundle.min.js?ver=1.0.2' id='civic-science-js'></script>
<script src='https://www.nbcchicago.com/wp-content/themes/nbc-station/client/build/js/newsletterWidget.6e356532438669539229.bundle.min.js?ver=1.0.2' id='newsletter-widget-js'></script>
<script src='https://z.moatads.com/nbcuyieldheader7581548001/moatheader.js?ver=1.0.0' id='moat-js'></script>
<script src='https://stats.wp.com/e-202136.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:9.4.1',blog:'165596126',post:'2609969',tz:'-5',srv:'www.nbcchicago.com'} ]);
	_stq.push([ 'clickTrackerInit', '165596126', '2609969' ]);
</script>

</body>
</html>
